Commit 76a5f8e6 authored by Jonne Haß's avatar Jonne Haß Committed by GitHub
Browse files

Merge pull request #6982 from svbergerem/update-gems

Update gems
parents 3dd2f215 7c6cbf36
......@@ -17,7 +17,7 @@ gem "diaspora_federation-rails", "0.1.3"
# API and JSON
gem "acts_as_api", "0.4.2"
gem "acts_as_api", "0.4.3"
gem "json", "1.8.3"
gem "json-schema", "2.6.2"
......@@ -42,7 +42,7 @@ gem "sidekiq-cron", "0.4.2"
# Compression
gem "uglifier", "3.0.0"
gem "uglifier", "3.0.1"
# Configuration
......@@ -54,10 +54,10 @@ gem "rack-cors", "0.4.0", require: "rack/cors"
# CSS
gem "bootstrap-sass", "3.3.6"
gem "bootstrap-sass", "3.3.7"
gem "compass-rails", "2.0.5"
gem "sass-rails", "5.0.4"
gem "autoprefixer-rails", "6.3.6.2"
gem "sass-rails", "5.0.6"
gem "autoprefixer-rails", "6.4.0.2"
gem "bootstrap-switch-rails", "3.3.3"
# Database
......@@ -70,7 +70,7 @@ group :postgresql, optional: true do
end
gem "activerecord-import", "0.13.0"
gem "activerecord-import", "0.15.0"
# File uploading
......@@ -89,32 +89,32 @@ gem "entypo-rails", "3.0.0.pre.rc2"
# JavaScript
gem "backbone-on-rails", "1.2.0.0"
gem "handlebars_assets", "0.23.0"
gem "handlebars_assets", "0.23.1"
gem "jquery-rails", "4.1.1"
gem "jquery-ui-rails", "5.0.5"
gem "js_image_paths", "0.1.0"
gem "js-routes", "1.2.6"
gem "js-routes", "1.2.9"
source "https://rails-assets.org" do
gem "rails-assets-jquery", "2.2.1" # Should be kept in sync with jquery-rails
gem "rails-assets-markdown-it", "6.0.5"
gem "rails-assets-markdown-it", "7.0.0"
gem "rails-assets-markdown-it-hashtag", "0.4.0"
gem "rails-assets-markdown-it-diaspora-mention", "0.4.0"
gem "rails-assets-markdown-it-diaspora-mention", "1.0.0"
gem "rails-assets-markdown-it-sanitizer", "0.4.2"
gem "rails-assets-markdown-it--markdown-it-for-inline", "0.1.1"
gem "rails-assets-markdown-it-sub", "1.0.0"
gem "rails-assets-markdown-it-sup", "1.0.0"
gem "rails-assets-highlightjs", "9.4.0"
gem "rails-assets-bootstrap-markdown", "2.9.0"
gem "rails-assets-highlightjs", "9.6.0"
gem "rails-assets-bootstrap-markdown", "2.10.0"
# jQuery plugins
gem "rails-assets-jquery-placeholder", "2.3.1"
gem "rails-assets-jquery-textchange", "0.2.3"
gem "rails-assets-perfect-scrollbar", "0.6.11"
gem "rails-assets-autosize", "3.0.15"
gem "rails-assets-blueimp-gallery", "2.21.2"
gem "rails-assets-perfect-scrollbar", "0.6.12"
gem "rails-assets-autosize", "3.0.17"
gem "rails-assets-blueimp-gallery", "2.21.3"
end
# Localization
......@@ -134,21 +134,21 @@ gem "leaflet-rails", "0.7.7"
gem "nokogiri", "1.6.8"
gem "redcarpet", "3.3.4"
gem "twitter-text", "1.13.4"
gem "twitter-text", "1.14.0"
gem "ruby-oembed", "0.10.1"
gem "open_graph_reader", "0.6.1"
# Services
gem "omniauth", "1.3.1"
gem "omniauth-facebook", "3.0.0"
gem "omniauth-facebook", "4.0.0"
gem "omniauth-tumblr", "1.2"
gem "omniauth-twitter", "1.2.1"
gem "twitter", "5.16.0"
gem "omniauth-wordpress", "0.2.2"
# OpenID Connect
gem "openid_connect", "0.11.2"
gem "openid_connect", "0.12.0"
# Serializers
......@@ -168,11 +168,11 @@ gem "addressable", "2.3.8", require: "addressable/uri"
gem "faraday", "0.9.2"
gem "faraday_middleware", "0.10.0"
gem "faraday-cookie_jar", "0.0.6"
gem "typhoeus", "1.0.2"
gem "typhoeus", "1.1.0"
# Views
gem "gon", "6.0.1"
gem "gon", "6.1.0"
gem "hamlit", "2.5.0"
gem "mobile-fu", "1.3.1"
gem "will_paginate", "3.1.0"
......@@ -241,7 +241,7 @@ group :development do
# Linters
gem "rubocop", "0.40.0"
gem "haml_lint", "0.17.1"
gem "haml_lint", "0.18.1"
gem "pronto", "0.7.0"
gem "pronto-eslint", "0.7.0"
gem "pronto-rubocop", "0.7.0"
......@@ -250,7 +250,7 @@ group :development do
# Preloading environment
gem "spring", "1.7.1"
gem "spring", "1.7.2"
gem "spring-commands-rspec", "1.0.4"
gem "spring-commands-cucumber", "1.0.1"
......@@ -268,8 +268,8 @@ group :test do
# RSpec (unit tests, some integration tests)
gem "fixture_builder", "0.4.1"
gem "fuubar", "2.0.0"
gem "test_after_commit", "1.0.0"
gem "fuubar", "2.1.1"
gem "test_after_commit", "1.1.0"
# Cucumber (integration tests)
......
......@@ -34,8 +34,8 @@ GEM
activemodel (= 4.2.7.1)
activesupport (= 4.2.7.1)
arel (~> 6.0)
activerecord-import (0.13.0)
activerecord (>= 3.0)
activerecord-import (0.15.0)
activerecord (>= 3.2)
activesupport (4.2.7.1)
i18n (~> 0.7)
json (~> 1.7, >= 1.7.7)
......@@ -44,7 +44,7 @@ GEM
tzinfo (~> 1.1)
acts-as-taggable-on (3.5.0)
activerecord (>= 3.2, < 5)
acts_as_api (0.4.2)
acts_as_api (0.4.3)
activemodel (>= 3.0.0)
activesupport (>= 3.0.0)
rack (>= 1.1.0)
......@@ -56,7 +56,7 @@ GEM
unf
ast (2.3.0)
attr_required (1.0.1)
autoprefixer-rails (6.3.6.2)
autoprefixer-rails (6.4.0.2)
execjs
backbone-on-rails (1.2.0.0)
eco
......@@ -64,8 +64,8 @@ GEM
jquery-rails
railties
bcrypt (3.1.11)
bindata (2.3.0)
bootstrap-sass (3.3.6)
bindata (2.3.1)
bootstrap-sass (3.3.7)
autoprefixer-rails (>= 5.2.1)
sass (>= 3.3.4)
bootstrap-switch-rails (3.3.3)
......@@ -104,14 +104,14 @@ GEM
timers (>= 4.1.1)
celluloid-pool (0.20.5)
timers (>= 4.1.1)
celluloid-supervision (0.20.5)
celluloid-supervision (0.20.6)
timers (>= 4.1.1)
chunky_png (1.3.5)
chunky_png (1.3.6)
cliver (0.3.2)
coderay (1.1.1)
coffee-rails (4.1.1)
coffee-rails (4.2.1)
coffee-script (>= 2.2.0)
railties (>= 4.0.0, < 5.1.x)
railties (>= 4.0.0, < 5.2.x)
coffee-script (2.4.1)
coffee-script-source
execjs
......@@ -191,7 +191,7 @@ GEM
factory_girl (~> 4.7)
diff-lcs (1.2.5)
docile (1.1.5)
domain_name (0.5.20160310)
domain_name (0.5.20160615)
unf (>= 0.0.5, < 1.0.0)
eco (1.0.0)
coffee-script
......@@ -362,20 +362,20 @@ GEM
fog-xml (0.1.2)
fog-core
nokogiri (~> 1.5, >= 1.5.11)
font-awesome-rails (4.6.3.0)
font-awesome-rails (4.6.3.1)
railties (>= 3.2, < 5.1)
formatador (0.2.5)
fuubar (2.0.0)
fuubar (2.1.1)
rspec (~> 3.0)
ruby-progressbar (~> 1.4)
get_process_mem (0.2.0)
get_process_mem (0.2.1)
gherkin (4.0.0)
gitlab (3.6.1)
httparty
terminal-table
globalid (0.3.7)
activesupport (>= 4.1.0)
gon (6.0.1)
gon (6.1.0)
actionpack (>= 3.0)
json
multi_json
......@@ -403,7 +403,7 @@ GEM
rubocop (~> 0.20)
haml (4.0.7)
tilt
haml_lint (0.17.1)
haml_lint (0.18.1)
haml (~> 4.0)
rake (>= 10, < 12)
rubocop (>= 0.36.0)
......@@ -412,7 +412,7 @@ GEM
temple (~> 0.7.6)
thor
tilt
handlebars_assets (0.23.0)
handlebars_assets (0.23.1)
execjs (~> 2.0)
multi_json (~> 1.0)
sprockets (>= 2.0.0)
......@@ -434,7 +434,7 @@ GEM
httparty (0.13.7)
json (~> 1.8)
multi_xml (>= 0.5.2)
httpclient (2.8.0)
httpclient (2.8.1)
i18n (0.7.0)
i18n-inflector (2.6.7)
i18n (>= 0.4.1)
......@@ -457,13 +457,13 @@ GEM
thor (>= 0.14, < 2.0)
jquery-ui-rails (5.0.5)
railties (>= 3.2.16)
js-routes (1.2.6)
js-routes (1.2.9)
railties (>= 3.2)
sprockets-rails
js_image_paths (0.1.0)
rails (~> 4.0)
json (1.8.3)
json-jwt (1.5.2)
json-jwt (1.6.3)
activesupport
bindata
multi_json (>= 1.3)
......@@ -476,7 +476,7 @@ GEM
rspec (>= 2.0, < 4.0)
jsonpath (0.5.8)
multi_json
jwt (1.5.1)
jwt (1.5.4)
kaminari (0.16.3)
actionpack (>= 3.0.0)
activesupport (>= 3.0.0)
......@@ -529,9 +529,9 @@ GEM
nenv (~> 0.1)
shellany (~> 0.0)
oauth (0.5.1)
oauth2 (1.1.0)
oauth2 (1.2.0)
faraday (>= 0.8, < 0.10)
jwt (~> 1.0, < 1.5.2)
jwt (~> 1.0)
multi_json (~> 1.3)
multi_xml (~> 0.5)
rack (>= 1.2, < 3)
......@@ -540,7 +540,7 @@ GEM
omniauth (1.3.1)
hashie (>= 1.2, < 4)
rack (>= 1.0, < 3)
omniauth-facebook (3.0.0)
omniauth-facebook (4.0.0)
omniauth-oauth2 (~> 1.2)
omniauth-oauth (1.1.0)
oauth
......@@ -559,12 +559,12 @@ GEM
open_graph_reader (0.6.1)
faraday (~> 0.9.0)
nokogiri (~> 1.6)
openid_connect (0.11.2)
openid_connect (0.12.0)
activemodel
attr_required (>= 1.0.0)
json (>= 1.4.3)
json-jwt (>= 1.5.0)
rack-oauth2 (>= 1.2.1)
rack-oauth2 (>= 1.3.1)
swd (>= 1.0.0)
tzinfo
validate_email
......@@ -616,7 +616,7 @@ GEM
activesupport
rack-mobile-detect (0.4.0)
rack
rack-oauth2 (1.3.0)
rack-oauth2 (1.4.0)
activesupport (>= 2.3)
attr_required (>= 0.0.5)
httpclient (>= 2.4)
......@@ -644,11 +644,11 @@ GEM
bundler (>= 1.3.0, < 2.0)
railties (= 4.2.7.1)
sprockets-rails
rails-assets-autosize (3.0.15)
rails-assets-blueimp-gallery (2.21.2)
rails-assets-bootstrap (3.3.6)
rails-assets-jquery (>= 1.9.1, < 3)
rails-assets-bootstrap-markdown (2.9.0)
rails-assets-autosize (3.0.17)
rails-assets-blueimp-gallery (2.21.3)
rails-assets-bootstrap (3.3.7)
rails-assets-jquery (>= 1.9.1, < 4)
rails-assets-bootstrap-markdown (2.10.0)
rails-assets-bootstrap (~> 3)
rails-assets-diaspora_jsxc (0.1.5.develop.1)
rails-assets-favico.js (~> 0.3.9)
......@@ -658,7 +658,7 @@ GEM
rails-assets-jquery.slimscroll (~> 1.3.6)
rails-assets-jquery.ui (~> 1.11.4)
rails-assets-favico.js (0.3.10)
rails-assets-highlightjs (9.4.0)
rails-assets-highlightjs (9.6.0)
rails-assets-jasmine (2.4.1)
rails-assets-jasmine-ajax (3.2.0)
rails-assets-jasmine (~> 2)
......@@ -670,17 +670,17 @@ GEM
rails-assets-jquery (>= 1.6)
rails-assets-jquery-textchange (0.2.3)
rails-assets-jquery
rails-assets-jquery.slimscroll (1.3.7)
rails-assets-jquery.slimscroll (1.3.8)
rails-assets-jquery.ui (1.11.4)
rails-assets-jquery (>= 1.6)
rails-assets-markdown-it--markdown-it-for-inline (0.1.1)
rails-assets-markdown-it (6.0.5)
rails-assets-markdown-it-diaspora-mention (0.4.0)
rails-assets-markdown-it (7.0.0)
rails-assets-markdown-it-diaspora-mention (1.0.0)
rails-assets-markdown-it-hashtag (0.4.0)
rails-assets-markdown-it-sanitizer (0.4.2)
rails-assets-markdown-it-sub (1.0.0)
rails-assets-markdown-it-sup (1.0.0)
rails-assets-perfect-scrollbar (0.6.11)
rails-assets-perfect-scrollbar (0.6.12)
rails-deprecated_sanitizer (1.0.3)
activesupport (>= 4.2.0.alpha)
rails-dom-testing (1.0.7)
......@@ -767,8 +767,8 @@ GEM
rugged (0.24.0)
safe_yaml (1.0.4)
sass (3.4.22)
sass-rails (5.0.4)
railties (>= 4.0.0, < 5.0)
sass-rails (5.0.6)
railties (>= 4.0.0, < 6)
sass (~> 3.1)
sprockets (>= 2.8, < 4.0)
sprockets-rails (>= 2.0, < 4.0)
......@@ -808,7 +808,7 @@ GEM
sinon-rails (1.15.0)
railties (>= 3.1)
slop (3.6.0)
spring (1.7.1)
spring (1.7.2)
spring-commands-cucumber (1.0.1)
spring (>= 0.9.1)
spring-commands-rspec (1.0.4)
......@@ -835,7 +835,7 @@ GEM
term-ansicolor (1.3.2)
tins (~> 1.0)
terminal-table (1.6.0)
test_after_commit (1.0.0)
test_after_commit (1.1.0)
activerecord (>= 3.2)
thor (0.19.1)
thread_safe (0.3.5)
......@@ -857,13 +857,13 @@ GEM
memoizable (~> 0.4.0)
naught (~> 1.0)
simple_oauth (~> 0.3.0)
twitter-text (1.13.4)
twitter-text (1.14.0)
unf (~> 0.1.0)
typhoeus (1.0.2)
typhoeus (1.1.0)
ethon (>= 0.9.0)
tzinfo (1.2.2)
thread_safe (~> 0.1)
uglifier (3.0.0)
uglifier (3.0.1)
execjs (>= 0.3.0, < 3)
unf (0.1.4)
unf_ext
......@@ -913,14 +913,14 @@ PLATFORMS
DEPENDENCIES
active_model_serializers (= 0.9.5)
activerecord-import (= 0.13.0)
activerecord-import (= 0.15.0)
acts-as-taggable-on (= 3.5.0)
acts_as_api (= 0.4.2)
acts_as_api (= 0.4.3)
addressable (= 2.3.8)
asset_sync (= 1.1.0)
autoprefixer-rails (= 6.3.6.2)
autoprefixer-rails (= 6.4.0.2)
backbone-on-rails (= 1.2.0.0)
bootstrap-sass (= 3.3.6)
bootstrap-sass (= 3.3.7)
bootstrap-switch-rails (= 3.3.3)
capybara (= 2.7.1)
carrierwave (= 0.11.2)
......@@ -944,22 +944,22 @@ DEPENDENCIES
faraday_middleware (= 0.10.0)
fixture_builder (= 0.4.1)
fog (= 1.38.0)
fuubar (= 2.0.0)
gon (= 6.0.1)
fuubar (= 2.1.1)
gon (= 6.1.0)
guard (= 2.14.0)
guard-cucumber (= 2.1.2)
guard-rspec (= 4.7.3)
guard-rubocop (= 1.2.0)
haml_lint (= 0.17.1)
haml_lint (= 0.18.1)
hamlit (= 2.5.0)
handlebars_assets (= 0.23.0)
handlebars_assets (= 0.23.1)
http_accept_language (= 2.0.5)
i18n-inflector-rails (= 1.0.7)
jasmine (= 2.4.0)
jasmine-jquery-rails (= 2.0.3)
jquery-rails (= 4.1.1)
jquery-ui-rails (= 5.0.5)
js-routes (= 1.2.6)
js-routes (= 1.2.9)
js_image_paths (= 0.1.0)
json (= 1.8.3)
json-schema (= 2.6.2)
......@@ -973,12 +973,12 @@ DEPENDENCIES
mysql2 (= 0.4.4)
nokogiri (= 1.6.8)
omniauth (= 1.3.1)
omniauth-facebook (= 3.0.0)
omniauth-facebook (= 4.0.0)
omniauth-tumblr (= 1.2)
omniauth-twitter (= 1.2.1)
omniauth-wordpress (= 0.2.2)
open_graph_reader (= 0.6.1)
openid_connect (= 0.11.2)
openid_connect (= 0.12.0)
pg (= 0.18.4)
poltergeist (= 1.10.0)
pronto (= 0.7.0)
......@@ -996,23 +996,23 @@ DEPENDENCIES
rack-rewrite (= 1.5.1)
rack-ssl (= 1.4.1)
rails (= 4.2.7.1)
rails-assets-autosize (= 3.0.15)!
rails-assets-blueimp-gallery (= 2.21.2)!
rails-assets-bootstrap-markdown (= 2.9.0)!
rails-assets-autosize (= 3.0.17)!
rails-assets-blueimp-gallery (= 2.21.3)!
rails-assets-bootstrap-markdown (= 2.10.0)!
rails-assets-diaspora_jsxc (= 0.1.5.develop.1)!
rails-assets-highlightjs (= 9.4.0)!
rails-assets-highlightjs (= 9.6.0)!
rails-assets-jasmine-ajax (= 3.2.0)!
rails-assets-jquery (= 2.2.1)!
rails-assets-jquery-placeholder (= 2.3.1)!
rails-assets-jquery-textchange (= 0.2.3)!
rails-assets-markdown-it (= 6.0.5)!
rails-assets-markdown-it (= 7.0.0)!
rails-assets-markdown-it--markdown-it-for-inline (= 0.1.1)!
rails-assets-markdown-it-diaspora-mention (= 0.4.0)!
rails-assets-markdown-it-diaspora-mention (= 1.0.0)!
rails-assets-markdown-it-hashtag (= 0.4.0)!
rails-assets-markdown-it-sanitizer (= 0.4.2)!
rails-assets-markdown-it-sub (= 1.0.0)!
rails-assets-markdown-it-sup (= 1.0.0)!
rails-assets-perfect-scrollbar (= 0.6.11)!
rails-assets-perfect-scrollbar (= 0.6.12)!
rails-i18n (= 4.0.8)
rails-timeago (= 2.11.0)
rails_admin (= 0.8.1)
......@@ -1025,7 +1025,7 @@ DEPENDENCIES
rubocop (= 0.40.0)
ruby-oembed (= 0.10.1)
rubyzip (= 1.2.0)
sass-rails (= 5.0.4)
sass-rails (= 5.0.6)
shoulda-matchers (= 3.1.1)
sidekiq (= 4.1.4)
sidekiq-cron (= 0.4.2)
......@@ -1033,16 +1033,16 @@ DEPENDENCIES
simplecov (= 0.12.0)
sinatra (= 1.4.7)
sinon-rails (= 1.15.0)
spring (= 1.7.1)
spring (= 1.7.2)
spring-commands-cucumber (= 1.0.1)
spring-commands-rspec (= 1.0.4)
test_after_commit (= 1.0.0)
test_after_commit (= 1.1.0)
timecop (= 0.8.1)
turbo_dev_assets (= 0.0.2)
twitter (= 5.16.0)
twitter-text (= 1.13.4)
typhoeus (= 1.0.2)
uglifier (= 3.0.0)
twitter-text (= 1.14.0)
typhoeus (= 1.1.0)
uglifier (= 3.0.1)
unicorn (= 5.1.0)
unicorn-worker-killer (= 0.4.4)
uuid (= 2.3.8)
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment